summaryrefslogtreecommitdiff
path: root/utils/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Lewycky <nicholas@mxc.ca>2010-06-23 06:48:34 +0000
committerNick Lewycky <nicholas@mxc.ca>2010-06-23 06:48:34 +0000
commitec4c02d252b4f2b3dda053c9c7c894832c91dfca (patch)
tree5f52729c03867052550f23c9b1dc4c3e2e82bf5a /utils/TableGen/CMakeLists.txt
parentd24c9d5f91442f893bebc2ea8d5ee845bc8b77a9 (diff)
downloadllvm-ec4c02d252b4f2b3dda053c9c7c894832c91dfca.tar.gz
llvm-ec4c02d252b4f2b3dda053c9c7c894832c91dfca.tar.bz2
llvm-ec4c02d252b4f2b3dda053c9c7c894832c91dfca.tar.xz
Don't link against libm and libpthread which don't exist in BeOS/Haiku. Also,
Haiku like Linux provides <regex.h>, so use it. Patch by Paul Davey! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@106620 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/TableGen/CMakeLists.txt')
-rw-r--r--utils/TableGen/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/TableGen/CMakeLists.txt b/utils/TableGen/CMakeLists.txt
index 85847f164b..972989ba62 100644
--- a/utils/TableGen/CMakeLists.txt
+++ b/utils/TableGen/CMakeLists.txt
@@ -41,6 +41,6 @@ target_link_libraries(tblgen LLVMSupport LLVMSystem)
if( MINGW )
target_link_libraries(tblgen imagehlp psapi)
endif( MINGW )
-if( LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD )
+if( LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD AND NOT BEOS )
target_link_libraries(tblgen pthread)
endif()