summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c315cbe4b..2e758f3fb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -565,3 +565,9 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
)
endif()
+option(WITH_POLLY "Build LLVM with Polly" ON)
+if(WITH_POLLY)
+ if(NOT EXISTS ${LLVM_MAIN_SRC_DIR}/tools/polly/CMakeLists.txt)
+ set(WITH_POLLY OFF)
+ endif()
+endif(WITH_POLLY)