summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8c3038eba..1d216924b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,8 +91,13 @@ set(LLVM_ALL_TARGETS
# List of targets with JIT support:
set(LLVM_TARGETS_WITH_JIT X86 PowerPC ARM Mips)
-set(LLVM_TARGETS_TO_BUILD "all"
+if( MSVC )
+ set(LLVM_TARGETS_TO_BUILD X86
+ CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
+else( MSVC )
+ set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
+endif( MSVC )
set(LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ""
CACHE STRING "Semicolon-separated list of experimental targets to build.")