summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index ad1fd1c632..393bd6a85a 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -510,6 +510,19 @@ case "$enableval" in
*) AC_MSG_ERROR([Invalid setting for --enable-cxx11. Use "yes" or "no"]) ;;
esac
+dnl --enable-fission : check whether or not to use -gsplit-dwarf on the command
+dnl line
+AC_ARG_ENABLE(split-dwarf,
+ AS_HELP_STRING([--enable-split-dwarf],
+ [Use split-dwarf if available (default is NO)]),,
+ enableval=default)
+case "$enableval" in
+ yes) AC_SUBST(ENABLE_SPLIT_DWARF,[1]) ;;
+ no) AC_SUBST(ENABLE_SPLIT_DWARF,[0]) ;;
+ default) AC_SUBST(ENABLE_SPLIT_DWARF,[0]);;
+ *) AC_MSG_ERROR([Invalid setting for --enable-split-dwarf. Use "yes" or "no"]) ;;
+esac
+
dnl --enable-clang-arcmt: check whether to enable clang arcmt
clang_arcmt="yes"
AC_ARG_ENABLE(clang-arcmt,