summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index be1f1ddf13..153ddfe439 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -307,9 +307,15 @@ AC_PATH_PROG(TAR, [tar], [gtar])
AC_PATH_PROG(GRAPHVIZ, [Graphviz], [echo Graphviz])
if test "$GRAPHVIZ" != "echo Graphviz" ; then
AC_DEFINE([HAVE_GRAPHVIZ],[1],[Define if the Graphviz program is available])
- AC_DEFINE([LLVM_PATH_GRAPHVIZ],"$GRAPHVIZ",
+ AC_DEFINE_UNQUOTED([LLVM_PATH_GRAPHVIZ],"$GRAPHVIZ",
[Define to path to Graphviz program if found or 'echo Graphviz' otherwise])
fi
+AC_PATH_PROG(GV, [gv], [echo gv])
+if test "$GRAPHVIZ" != "echo gv" ; then
+ AC_DEFINE([HAVE_GV],[1],[Define if the gv program is available])
+ AC_DEFINE_UNQUOTED([LLVM_PATH_GV],"$GV",
+ [Define to path to gv program if found or 'echo gv' otherwise])
+fi
dnl Find the install program
AC_PROG_INSTALL