summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 64b78a49eb..82539f07a5 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -796,6 +796,9 @@ if test "$ENABLE_THREADS" -eq 1 ; then
AC_SEARCH_LIBS(pthread_mutex_lock,pthread,
AC_DEFINE([HAVE_PTHREAD_MUTEX_LOCK],[1],
[Have pthread_mutex_lock]))
+ AC_SEARCH_LIBS(pthread_rwlock_init,pthread,
+ AC_DEFINE([HAVE_PTHREAD_RWLOCK_INIT],[1],
+ [Have pthread_rwlock_init]))
fi
dnl Allow extra x86-disassembler library