summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter4/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter4/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter4/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Kaleidoscope/Chapter4/CMakeLists.txt b/examples/Kaleidoscope/Chapter4/CMakeLists.txt
index 0d1ac533f0..7aa18b8898 100644
--- a/examples/Kaleidoscope/Chapter4/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter4/CMakeLists.txt
@@ -1,5 +1,6 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
-
add_llvm_example(Kaleidoscope-Ch4
toy.cpp
)
+
+add_llvm_link_components(Kaleidoscope-Ch4 jit interpreter native)
+target_link_libraries(Kaleidoscope-Ch4 LLVMCore)