summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter5/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter5/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/examples/Kaleidoscope/Chapter5/CMakeLists.txt b/examples/Kaleidoscope/Chapter5/CMakeLists.txt
index 33a0651f8c..2d75ad3592 100644
--- a/examples/Kaleidoscope/Chapter5/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter5/CMakeLists.txt
@@ -1,6 +1,5 @@
+set(LLVM_LINK_COMPONENTS core jit interpreter native)
+
add_llvm_example(Kaleidoscope-Ch5
toy.cpp
)
-
-add_llvm_link_components(Kaleidoscope-Ch5 jit interpreter native)
-target_link_libraries(Kaleidoscope-Ch5 LLVMCore)