summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter5/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter5/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/examples/Kaleidoscope/Chapter5/CMakeLists.txt b/examples/Kaleidoscope/Chapter5/CMakeLists.txt
index 2d75ad3592..c7d0276194 100644
--- a/examples/Kaleidoscope/Chapter5/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter5/CMakeLists.txt
@@ -1,4 +1,13 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ InstCombine
+ JIT
+ ScalarOpts
+ Support
+ nativecodegen
+ )
add_llvm_example(Kaleidoscope-Ch5
toy.cpp