summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter6/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter6/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter6/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Kaleidoscope/Chapter6/CMakeLists.txt b/examples/Kaleidoscope/Chapter6/CMakeLists.txt
index 2e15a5f7df..002e0d4670 100644
--- a/examples/Kaleidoscope/Chapter6/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter6/CMakeLists.txt
@@ -1,5 +1,6 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
-
add_llvm_example(Kaleidoscope-Ch6
toy.cpp
)
+
+add_llvm_link_components(Kaleidoscope-Ch6 jit interpreter native)
+target_link_libraries(Kaleidoscope-Ch6 LLVMCore)