summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter7/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter7/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter7/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Kaleidoscope/Chapter7/CMakeLists.txt b/examples/Kaleidoscope/Chapter7/CMakeLists.txt
index 9b8227c693..3c4ac17d93 100644
--- a/examples/Kaleidoscope/Chapter7/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter7/CMakeLists.txt
@@ -1,5 +1,6 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
-
add_llvm_example(Kaleidoscope-Ch7
toy.cpp
)
+
+add_llvm_link_components(Kaleidoscope-Ch7 jit interpreter native)
+target_link_libraries(Kaleidoscope-Ch7 LLVMCore)