summaryrefslogtreecommitdiff
path: root/examples/ParallelJIT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ParallelJIT/CMakeLists.txt')
-rw-r--r--examples/ParallelJIT/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/ParallelJIT/CMakeLists.txt b/examples/ParallelJIT/CMakeLists.txt
index fbdc6e5fc1..91ac5ef467 100644
--- a/examples/ParallelJIT/CMakeLists.txt
+++ b/examples/ParallelJIT/CMakeLists.txt
@@ -1,9 +1,9 @@
-set(LLVM_LINK_COMPONENTS jit interpreter nativecodegen)
-
add_llvm_example(ParallelJIT
ParallelJIT.cpp
)
+add_llvm_link_components(ParallelJIT jit interpreter nativecodegen)
+
if(HAVE_LIBPTHREAD)
target_link_libraries(ParallelJIT pthread)
endif(HAVE_LIBPTHREAD)