summaryrefslogtreecommitdiff
path: root/lib/Analysis/DataStructure/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Analysis/DataStructure/Makefile.am')
-rw-r--r--lib/Analysis/DataStructure/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/lib/Analysis/DataStructure/Makefile.am b/lib/Analysis/DataStructure/Makefile.am
new file mode 100644
index 0000000000..fcb3ffd4eb
--- /dev/null
+++ b/lib/Analysis/DataStructure/Makefile.am
@@ -0,0 +1,30 @@
+#===-- lib/Analysis/DataStructure/Makefile.am --------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+lib_LIBRARIES = libLLVMDataStructure.a
+
+libLLVMDataStructure_a_SOURCES = \
+ BottomUpClosure.cpp\
+ CompleteBottomUp.cpp\
+ DataStructureAA.cpp\
+ DataStructure.cpp\
+ DataStructureOpt.cpp\
+ DataStructureStats.cpp\
+ DependenceGraph.cpp\
+ GraphChecker.cpp\
+ IPModRef.cpp\
+ Local.cpp\
+ MemoryDepAnalysis.cpp\
+ Parallelize.cpp\
+ PgmDependenceGraph.cpp\
+ Printer.cpp\
+ Steensgaard.cpp\
+ TopDownClosure.cpp