summaryrefslogtreecommitdiff
path: root/lib/CodeGen/InstrSched/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CodeGen/InstrSched/Makefile.am')
-rw-r--r--lib/CodeGen/InstrSched/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/CodeGen/InstrSched/Makefile.am b/lib/CodeGen/InstrSched/Makefile.am
new file mode 100644
index 0000000000..f8c1433ad2
--- /dev/null
+++ b/lib/CodeGen/InstrSched/Makefile.am
@@ -0,0 +1,23 @@
+#===-- lib/CodeGen/InstrSched/Makefile.am ------------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+lib_LIBRARIES = libLLVMInstrSched.a
+libexec_PROGRAMS = LLVMInstrSched.o
+
+MYSOURCES = \
+ InstrScheduling.cpp \
+ SchedGraphCommon.cpp \
+ SchedGraph.cpp \
+ SchedPriorities.cpp
+
+libLLVMInstrSched_a_SOURCES = $(MYSOURCES)
+LLVMInstrSched_o_SOURCES = $(MYSOURCES)
+LIBS=