summaryrefslogtreecommitdiff
path: root/lib/CodeGen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CodeGen/Makefile.am')
-rw-r--r--lib/CodeGen/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/CodeGen/Makefile.am b/lib/CodeGen/Makefile.am
index 0f3cdd2fd5..68d09369a5 100644
--- a/lib/CodeGen/Makefile.am
+++ b/lib/CodeGen/Makefile.am
@@ -7,13 +7,13 @@
#
#===------------------------------------------------------------------------===#
-include $(top_srcdir)/Makefile.rules.am
+include $(top_srcdir)/Makefile_config
SUBDIRS = SelectionDAG
-libexec_PROGRAMS = LLVMCodeGen.o
+lib_LIBRARIES = libLLVMCodeGen.a
-LLVMCodeGen_o_SOURCES = \
+libLLVMCodeGen_a_SOURCES = \
AsmPrinter.cpp \
BranchFolding.cpp \
IntrinsicLowering.cpp \
@@ -35,4 +35,4 @@ LLVMCodeGen_o_SOURCES = \
UnreachableBlockElim.cpp \
VirtRegMap.cpp
-LIBS=
+PRELINK=libLLVMCodeGen.a