summaryrefslogtreecommitdiff
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
new file mode 100644
index 0000000000..e27a651269
--- /dev/null
+++ b/lib/Support/CMakeLists.txt
@@ -0,0 +1,29 @@
+add_llvm_library(LLVMSupport
+ APFloat.cpp
+ APInt.cpp
+ APSInt.cpp
+ Allocator.cpp
+ Annotation.cpp
+ CommandLine.cpp
+ ConstantRange.cpp
+ Debug.cpp
+ Dwarf.cpp
+ FileUtilities.cpp
+ FoldingSet.cpp
+ GraphWriter.cpp
+ IsInf.cpp
+ IsNAN.cpp
+ ManagedStatic.cpp
+ MemoryBuffer.cpp
+ PluginLoader.cpp
+ SlowOperationInformer.cpp
+ SmallPtrSet.cpp
+ Statistic.cpp
+ Streams.cpp
+ StringExtras.cpp
+ StringMap.cpp
+ StringPool.cpp
+ SystemUtils.cpp
+ Timer.cpp
+ raw_ostream.cpp
+ )