summaryrefslogtreecommitdiff
path: root/lib/Support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Support/Makefile.am')
-rw-r--r--lib/Support/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/lib/Support/Makefile.am b/lib/Support/Makefile.am
new file mode 100644
index 0000000000..dce817c9dc
--- /dev/null
+++ b/lib/Support/Makefile.am
@@ -0,0 +1,29 @@
+#===-- lib/Support/Makefile.am -----------------------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+lib_LIBRARIES = libLLVMSupport.a
+
+libLLVMSupport_a_SOURCES = \
+ Annotation.cpp \
+ CommandLine.cpp \
+ Compressor.cpp \
+ Debug.cpp \
+ DynamicLinker.cpp \
+ FileUtilities.cpp \
+ IsInf.cpp \
+ IsNAN.cpp \
+ PluginLoader.cpp \
+ SlowOperationInformer.cpp \
+ Statistic.cpp \
+ StringExtras.cpp \
+ SystemUtils.cpp \
+ Timer.cpp \
+ ToolRunner.cpp