summaryrefslogtreecommitdiff
path: root/lib/Target/SparcV9/RegAlloc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/SparcV9/RegAlloc/Makefile.am')
-rw-r--r--lib/Target/SparcV9/RegAlloc/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/Target/SparcV9/RegAlloc/Makefile.am b/lib/Target/SparcV9/RegAlloc/Makefile.am
new file mode 100644
index 0000000000..f181d1569b
--- /dev/null
+++ b/lib/Target/SparcV9/RegAlloc/Makefile.am
@@ -0,0 +1,24 @@
+#===-- lib/Target/SparcV9/RegAlloc/Makefile.am -------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+lib_LIBRARIES = libLLVMSparcV9RegAlloc.a
+libexec_PROGRAMS = LLVMSparcV9RegAlloc.o
+
+MYSOURCES = \
+ IGNode.cpp \
+ InterferenceGraph.cpp \
+ LiveRangeInfo.cpp \
+ PhyRegAlloc.cpp \
+ RegClass.cpp
+
+libLLVMSparcV9RegAlloc_a_SOURCES = $(MYSOURCES)
+LLVMSparcV9RegAlloc_o_SOURCES = $(MYSOURCES)
+LIBS=