summaryrefslogtreecommitdiff
path: root/lib/Transforms/IPO/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/IPO/Makefile.am')
-rw-r--r--lib/Transforms/IPO/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/Transforms/IPO/Makefile.am b/lib/Transforms/IPO/Makefile.am
new file mode 100644
index 0000000000..c10360ff92
--- /dev/null
+++ b/lib/Transforms/IPO/Makefile.am
@@ -0,0 +1,35 @@
+#===-- lib/Transforms/IPO/Makefile.am ----------------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+lib_LIBRARIES = libLLVMIPO.a
+libexec_PROGRAMS = LLVMIPO.o
+
+MYSOURCES= \
+ ArgumentPromotion.cpp \
+ ConstantMerge.cpp \
+ DeadArgumentElimination.cpp \
+ DeadTypeElimination.cpp \
+ ExtractFunction.cpp \
+ FunctionResolution.cpp \
+ GlobalDCE.cpp \
+ GlobalOpt.cpp \
+ Inliner.cpp \
+ InlineSimple.cpp \
+ Internalize.cpp \
+ IPConstantPropagation.cpp \
+ LoopExtractor.cpp \
+ LowerSetJmp.cpp \
+ PruneEH.cpp \
+ RaiseAllocations.cpp
+
+libLLVMIPO_a_SOURCES = $(MYSOURCES)
+LLVMIPO_o_SOURCES = $(MYSOURCES)
+LIBS=