summaryrefslogtreecommitdiff
path: root/lib/Transforms/IPO/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/IPO/Makefile.am')
-rw-r--r--lib/Transforms/IPO/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/lib/Transforms/IPO/Makefile.am b/lib/Transforms/IPO/Makefile.am
index c10360ff92..e71892ae5f 100644
--- a/lib/Transforms/IPO/Makefile.am
+++ b/lib/Transforms/IPO/Makefile.am
@@ -7,10 +7,9 @@
#
#===------------------------------------------------------------------------===#
-include $(top_srcdir)/Makefile.rules.am
+include $(top_srcdir)/Makefile_config
lib_LIBRARIES = libLLVMIPO.a
-libexec_PROGRAMS = LLVMIPO.o
MYSOURCES= \
ArgumentPromotion.cpp \
@@ -31,5 +30,5 @@ MYSOURCES= \
RaiseAllocations.cpp
libLLVMIPO_a_SOURCES = $(MYSOURCES)
-LLVMIPO_o_SOURCES = $(MYSOURCES)
-LIBS=
+
+PRELINK=libLLVMIPO.a