summaryrefslogtreecommitdiff
path: root/lib/Transforms/InstCombine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/InstCombine/CMakeLists.txt')
-rw-r--r--lib/Transforms/InstCombine/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/Transforms/InstCombine/CMakeLists.txt b/lib/Transforms/InstCombine/CMakeLists.txt
index 5b1ff3e23b..4330377850 100644
--- a/lib/Transforms/InstCombine/CMakeLists.txt
+++ b/lib/Transforms/InstCombine/CMakeLists.txt
@@ -9,9 +9,14 @@ add_llvm_library(LLVMInstCombine
InstCombineMulDivRem.cpp
InstCombinePHI.cpp
InstCombineSelect.cpp
- InstCombineShifts.cpp
+ InstCombineShifts.cpp
InstCombineSimplifyDemanded.cpp
InstCombineVectorOps.cpp
)
-target_link_libraries (LLVMInstCombine LLVMTransformUtils)
+target_link_libraries(LLVMInstCombine
+ LLVMAnalysis
+ LLVMCore
+ LLVMTarget
+ LLVMTransformUtils
+ )