summaryrefslogtreecommitdiff
path: root/lib/VMCore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/VMCore/Makefile.am')
-rw-r--r--lib/VMCore/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/lib/VMCore/Makefile.am b/lib/VMCore/Makefile.am
new file mode 100644
index 0000000000..f9efdf6106
--- /dev/null
+++ b/lib/VMCore/Makefile.am
@@ -0,0 +1,37 @@
+#===-- lib/VMCore/Makefile.am ------------------------------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+libexec_PROGRAMS = LLVMCore.o
+
+LLVMCore_o_SOURCES = \
+ AsmWriter.cpp \
+ BasicBlock.cpp \
+ ConstantFolding.cpp \
+ ConstantRange.cpp \
+ Constants.cpp \
+ Dominators.cpp \
+ Function.cpp \
+ Globals.cpp \
+ InstrTypes.cpp \
+ Instruction.cpp \
+ Instructions.cpp \
+ LeakDetector.cpp \
+ Linker.cpp \
+ Mangler.cpp \
+ Module.cpp \
+ ModuleProvider.cpp \
+ Pass.cpp \
+ SymbolTable.cpp \
+ Type.cpp \
+ Value.cpp \
+ Verifier.cpp
+
+LIBS=