summaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
new file mode 100644
index 0000000000..78e12fd34a
--- /dev/null
+++ b/projects/CMakeLists.txt
@@ -0,0 +1,9 @@
+# Discover the projects that use CMake in the subdirectories.
+# Note that explicit cmake invocation is required every time a new project is
+# added or removed.
+file(GLOB entries *)
+foreach(entry ${entries})
+ if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
+ add_subdirectory(${entry})
+ endif()
+endforeach(entry)