summaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
index 415530e332..dac637335b 100644
--- a/projects/CMakeLists.txt
+++ b/projects/CMakeLists.txt
@@ -4,7 +4,8 @@
file(GLOB entries *)
foreach(entry ${entries})
if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
- if(NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt)
+ if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
+ (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
add_subdirectory(${entry})
endif()
endif()