summaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
index de06b78423..fc6483ca35 100644
--- a/projects/CMakeLists.txt
+++ b/projects/CMakeLists.txt
@@ -14,7 +14,11 @@ endforeach(entry)
# Also add in libc++ and compiler-rt trees if present (and we have
# a sufficiently recent version of CMake where required).
if(${LLVM_BUILD_RUNTIME})
- add_llvm_external_project(libcxx)
+ # MSVC isn't quite working with libc++ yet, disable it until issues are
+ # fixed.
+ if(NOT MSVC)
+ add_llvm_external_project(libcxx)
+ endif()
if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
add_llvm_external_project(compiler-rt)
else()