summaryrefslogtreecommitdiff
path: root/tools/bugpoint-passes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bugpoint-passes/CMakeLists.txt')
-rw-r--r--tools/bugpoint-passes/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/bugpoint-passes/CMakeLists.txt b/tools/bugpoint-passes/CMakeLists.txt
index 05f190a2a5..b7ee62673c 100644
--- a/tools/bugpoint-passes/CMakeLists.txt
+++ b/tools/bugpoint-passes/CMakeLists.txt
@@ -2,6 +2,14 @@ if( NOT LLVM_BUILD_TOOLS )
set(EXCLUDE_FROM_ALL ON)
endif()
+# If we don't need RTTI or EH, there's no reason to export anything
+# from this plugin.
+if( NOT LLVM_REQUIRES_RTTI )
+ if( NOT LLVM_REQUIRES_EH )
+ set(LLVM_EXPORTED_SYMBOL_FILE ${CMAKE_CURRENT_SOURCE_DIR}/bugpoint.exports)
+ endif()
+endif()
+
add_llvm_loadable_module( BugpointPasses
TestPasses.cpp
)