summaryrefslogtreecommitdiff
path: root/tools/bugpoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bugpoint/CMakeLists.txt')
-rw-r--r--tools/bugpoint/CMakeLists.txt13
1 files changed, 3 insertions, 10 deletions
diff --git a/tools/bugpoint/CMakeLists.txt b/tools/bugpoint/CMakeLists.txt
index 731c7bf6f9..e06feb1003 100644
--- a/tools/bugpoint/CMakeLists.txt
+++ b/tools/bugpoint/CMakeLists.txt
@@ -1,3 +1,6 @@
+set(LLVM_LINK_COMPONENTS asmparser instrumentation scalaropts ipo
+ linker bitreader bitwriter)
+
add_llvm_tool(bugpoint
BugDriver.cpp
CrashDebugger.cpp
@@ -9,13 +12,3 @@ add_llvm_tool(bugpoint
ToolRunner.cpp
bugpoint.cpp
)
-
-target_link_libraries(bugpoint
- LLVMAsmParser
- LLVMInstrumentation
- LLVMScalarOpts
- LLVMipo
- LLVMLinker
- LLVMBitReader
- LLVMBitWriter
- )