summaryrefslogtreecommitdiff
path: root/tools/bugpoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bugpoint/CMakeLists.txt')
-rw-r--r--tools/bugpoint/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/tools/bugpoint/CMakeLists.txt b/tools/bugpoint/CMakeLists.txt
index 0000d977ac..7e7ad0e94c 100644
--- a/tools/bugpoint/CMakeLists.txt
+++ b/tools/bugpoint/CMakeLists.txt
@@ -1,5 +1,20 @@
-set(LLVM_LINK_COMPONENTS asmparser instrumentation scalaropts ipo
- linker bitreader bitwriter irreader vectorize objcarcopts)
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ BitWriter
+ Core
+ IPA
+ IPO
+ IRReader
+ InstCombine
+ Instrumentation
+ Linker
+ ObjCARCOpts
+ ScalarOpts
+ Support
+ Target
+ TransformUtils
+ Vectorize
+ )
add_llvm_tool(bugpoint
BugDriver.cpp