summaryrefslogtreecommitdiff
path: root/tools/bugpoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bugpoint/CMakeLists.txt')
-rw-r--r--tools/bugpoint/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/bugpoint/CMakeLists.txt b/tools/bugpoint/CMakeLists.txt
index b537a5d237..d71e097918 100644
--- a/tools/bugpoint/CMakeLists.txt
+++ b/tools/bugpoint/CMakeLists.txt
@@ -32,3 +32,12 @@ add_llvm_tool(bugpoint
bugpoint.cpp
)
set_target_properties(bugpoint PROPERTIES ENABLE_EXPORTS 1)
+
+if(WITH_POLLY AND LINK_POLLY_INTO_TOOLS)
+ target_link_libraries(bugpoint Polly)
+ if(POLLY_LINK_LIBS)
+ foreach(lib ${POLLY_LINK_LIBS})
+ target_link_libraries(bugpoint ${lib})
+ endforeach(lib)
+ endif(POLLY_LINK_LIBS)
+endif(WITH_POLLY AND LINK_POLLY_INTO_TOOLS)