summaryrefslogtreecommitdiff
path: root/tools/llc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llc/CMakeLists.txt')
-rw-r--r--tools/llc/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/tools/llc/CMakeLists.txt b/tools/llc/CMakeLists.txt
index 798578e7bb..683f29862d 100644
--- a/tools/llc/CMakeLists.txt
+++ b/tools/llc/CMakeLists.txt
@@ -1,6 +1,5 @@
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser)
+
add_llvm_tool(llc
llc.cpp
)
-
-add_llvm_link_components(llc all)
-target_link_libraries(llc LLVMBitReader LLVMAsmParser)