summaryrefslogtreecommitdiff
path: root/tools/llvm-c-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-c-test/CMakeLists.txt')
-rw-r--r--tools/llvm-c-test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/llvm-c-test/CMakeLists.txt b/tools/llvm-c-test/CMakeLists.txt
new file mode 100644
index 0000000000..2926d9dd34
--- /dev/null
+++ b/tools/llvm-c-test/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(LLVM_LINK_COMPONENTS all)
+
+if (LLVM_COMPILER_IS_GCC_COMPATIBLE)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wstrict-prototypes")
+endif ()
+
+add_llvm_tool(llvm-c-test
+ calc.c
+ disassemble.c
+ helpers.c
+ include-all.c
+ main.c
+ module.c
+ object.c
+ targets.c
+ )