summaryrefslogtreecommitdiff
path: root/tools/llvm-jitlistener/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-jitlistener/CMakeLists.txt')
-rw-r--r--tools/llvm-jitlistener/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/llvm-jitlistener/CMakeLists.txt b/tools/llvm-jitlistener/CMakeLists.txt
new file mode 100644
index 0000000000..57a4a0cbe1
--- /dev/null
+++ b/tools/llvm-jitlistener/CMakeLists.txt
@@ -0,0 +1,20 @@
+# This tool is excluded from the CMake build if Intel JIT events are disabled.
+
+link_directories( ${LLVM_INTEL_JITEVENTS_LIBDIR} )
+include_directories( ${LLVM_INTEL_JITEVENTS_INCDIR} )
+
+set(LLVM_LINK_COMPONENTS
+ asmparser
+ bitreader
+ inteljitevents
+ interpreter
+ jit
+ mcjit
+ nativecodegen
+ object
+ selectiondag
+ )
+
+add_llvm_tool(llvm-jitlistener
+ llvm-jitlistener.cpp
+ )