summaryrefslogtreecommitdiff
path: root/tools/llvm-symbolizer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-symbolizer/CMakeLists.txt')
-rw-r--r--tools/llvm-symbolizer/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/llvm-symbolizer/CMakeLists.txt b/tools/llvm-symbolizer/CMakeLists.txt
new file mode 100644
index 0000000000..5e274630c8
--- /dev/null
+++ b/tools/llvm-symbolizer/CMakeLists.txt
@@ -0,0 +1,13 @@
+# FIXME: As we plan to execute llvm-symbolizer binary from compiler-rt
+# libraries, it has to be compiled for all supported targets (x86_64, i386 etc).
+# This means that we need LLVM libraries to be compiled for these
+# targets as well. Currently, there is no support for such a build strategy.
+
+set(LLVM_LINK_COMPONENTS
+ DebugInfo
+ Object
+ )
+
+add_llvm_tool(llvm-symbolizer
+ llvm-symbolizer.cpp
+ )