summaryrefslogtreecommitdiff
path: root/tools/lto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lto/CMakeLists.txt')
-rw-r--r--tools/lto/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/lto/CMakeLists.txt b/tools/lto/CMakeLists.txt
new file mode 100644
index 0000000000..a316ef788e
--- /dev/null
+++ b/tools/lto/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(LLVM_LINK_COMPONENTS ipo scalaropts linker bitreader bitwriter)
+
+add_definitions( -DLLVM_VERSION_INFO=\"${PACKAGE_VERSION}\" )
+
+# TODO: build a static library too.
+set(BUILD_SHARED_LIBS ON)
+
+add_llvm_library(LTO
+ LTOCodeGenerator.cpp
+ lto.cpp
+ LTOModule.cpp
+ )
+