summaryrefslogtreecommitdiff
path: root/unittests/ExecutionEngine/JIT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/ExecutionEngine/JIT/CMakeLists.txt')
-rw-r--r--unittests/ExecutionEngine/JIT/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/unittests/ExecutionEngine/JIT/CMakeLists.txt b/unittests/ExecutionEngine/JIT/CMakeLists.txt
index d5e0b2eea8..72c1df7463 100644
--- a/unittests/ExecutionEngine/JIT/CMakeLists.txt
+++ b/unittests/ExecutionEngine/JIT/CMakeLists.txt
@@ -51,6 +51,9 @@ if(MSVC)
list(APPEND JITTestsSources JITTests.def)
endif()
+# The JIT tests need to dlopen things.
+set(LLVM_NO_DEAD_STRIP 1)
+
add_llvm_unittest(JITTests
${JITTestsSources}
)