summaryrefslogtreecommitdiff
path: root/unittests/IR/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/IR/CMakeLists.txt')
-rw-r--r--unittests/IR/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/unittests/IR/CMakeLists.txt b/unittests/IR/CMakeLists.txt
new file mode 100644
index 0000000000..4ff94f7035
--- /dev/null
+++ b/unittests/IR/CMakeLists.txt
@@ -0,0 +1,36 @@
+set(LLVM_LINK_COMPONENTS
+ asmparser
+ core
+ ipa
+ )
+
+set(IRSources
+ ConstantsTest.cpp
+ DominatorTreeTest.cpp
+ IRBuilderTest.cpp
+ InstructionsTest.cpp
+ MDBuilderTest.cpp
+ MetadataTest.cpp
+ PassManagerTest.cpp
+ TypeBuilderTest.cpp
+ TypesTest.cpp
+ ValueMapTest.cpp
+ VerifierTest.cpp
+ WaymarkTest.cpp
+ )
+
+# MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug.
+# See issue#331418 in Visual Studio.
+if(MSVC AND MSVC_VERSION LESS 1600)
+ list(REMOVE_ITEM IRSources ValueMapTest.cpp)
+endif()
+
+# HACK: Declare a couple of source files as optionally compiled to satisfy the
+# missing-file-checker in LLVM's weird CMake build.
+set(LLVM_OPTIONAL_SOURCES
+ ValueMapTest.cpp
+ )
+
+add_llvm_unittest(IRTests
+ ${IRSources}
+ )