summaryrefslogtreecommitdiff
path: root/unittests/Option/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/Option/CMakeLists.txt')
-rw-r--r--unittests/Option/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/unittests/Option/CMakeLists.txt b/unittests/Option/CMakeLists.txt
new file mode 100644
index 0000000000..185d503912
--- /dev/null
+++ b/unittests/Option/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(LLVM_LINK_COMPONENTS
+ Option
+ Support
+ )
+
+set(LLVM_TARGET_DEFINITIONS Opts.td)
+
+tablegen(LLVM Opts.inc -gen-opt-parser-defs)
+add_public_tablegen_target(OptsTestTableGen)
+
+add_llvm_unittest(OptionTests
+ OptionParsingTest.cpp
+ )
+
+add_dependencies(OptionTests OptsTestTableGen)