summaryrefslogtreecommitdiff
path: root/utils/not/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/not/CMakeLists.txt')
-rw-r--r--utils/not/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/not/CMakeLists.txt b/utils/not/CMakeLists.txt
new file mode 100644
index 0000000000..407c82eeea
--- /dev/null
+++ b/utils/not/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_executable(not
+ not.cpp
+ )
+
+target_link_libraries(not LLVMSystem)
+if( MINGW )
+ target_link_libraries(not imagehlp psapi)
+endif( MINGW )
+if( LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD )
+ target_link_libraries(not pthread)
+endif()