summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2002-12-30 00:51:30 +0000
committerRoland McGrath <roland@redhat.com>2002-12-30 00:51:30 +0000
commit6d2b34971b33d379c89c36c5ad1b0c6d5d12c453 (patch)
tree5b4bfe0ef2375b3cdadf9dd9f339e3267228b603 /Makefile.am
parente4d289013916c73187d461bb8f4b4010f6cf3f5a (diff)
downloadstrace-6d2b34971b33d379c89c36c5ad1b0c6d5d12c453.tar.gz
strace-6d2b34971b33d379c89c36c5ad1b0c6d5d12c453.tar.bz2
strace-6d2b34971b33d379c89c36c5ad1b0c6d5d12c453.tar.xz
2002-12-22 Roland McGrath <roland@redhat.com>
Update to Autoconf 2.57, and Automakify with version 1.7. * Makefile.am: New file. * Makefile.in: File removed. * configure.in: Moved to ... * configure.ac: ... here. Update for Autoconf 2.5x and Automake. * aclocal.m4: Moved to ... * acinclude.m4: ... here. Update for Autoconf 2.5x. * AUTHORS: New file, makes automake happy. * autogen.sh: File removed. * README-CVS: Update to recommend autoreconf instead. * file.c: HAVE_ST_* -> HAVE_STRUCT_STAT_ST_*. * net.c: HAVE_SIN6_SCOPE_ID -> HAVE_STRUCT_SOCKADDR_IN6_SIN6_SCOPE_ID, HAVE_MSG_CONTROL -> HAVE_STRUCT_MSGHDR_MSG_CONTROL. * strace.c: *_DECLARED -> HAVE_DECL_* * stream.c: HAVE_* -> HAVE_STRUCT_*
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8a76800
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+# Automake input for strace.
+
+bin_PROGRAMS = strace
+man_MANS = strace.1
+
+# OS is one of `linux', `sunos4', `svr4', or `freebsd'.
+OS = @opsys@
+# ARCH is `i386', `m68k', `sparc', etc.
+ARCH = @arch@
+# OSARCH is OS/ARCH if a makefile exists there, otherwise just OS.
+OSARCH = @osarch@
+
+INCLUDES = -I$(OS)/$(ARCH) -I$(srcdir)/$(OS)/$(ARCH) -I$(OS) -I$(srcdir)/$(OS)
+
+SUBDIRS = $(OSARCH)
+DIST_SUBDIRS = test freebsd/i386 sunos4 svr4 linux
+
+strace_SOURCES = strace.c version.c syscall.c util.c desc.c file.c ipc.c \
+ io.c ioctl.c mem.c net.c process.c bjm.c \
+ resource.c signal.c sock.c system.c term.c time.c \
+ proc.c stream.c
+
+EXTRA_DIST = $(man_MANS) errnoent.sh signalent.sh syscallent.sh ioctlsort.c