summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2004-07-12 06:11:03 +0000
committerRoland McGrath <roland@redhat.com>2004-07-12 06:11:03 +0000
commitadc2b308a1ce896d7aeaa4c7527e36fb0b3251fe (patch)
treef6127a11ab42013f909762a2060c5037954e8d23 /Makefile.am
parent16110b23a0cf9a271a4d06e271ff193e7bd1817e (diff)
downloadstrace-adc2b308a1ce896d7aeaa4c7527e36fb0b3251fe.tar.gz
strace-adc2b308a1ce896d7aeaa4c7527e36fb0b3251fe.tar.bz2
strace-adc2b308a1ce896d7aeaa4c7527e36fb0b3251fe.tar.xz
Tweak maintainer rules.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6612d2c..2a1c115 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,7 @@ if MAINTAINER_MODE
if LINUX
IOCTLDIR = /usr/include
+IOCTLASM = asm
if I386
ioctlent_h = linux/ioctlent.h
@@ -81,9 +82,10 @@ BUILT_SOURCES = $(ioctlent_h)
$(srcdir)/$(ioctlent_h): ioctlsort
$(<D)/$(<F) > $@
ioctlsort: $(srcdir)/linux/ioctlsort.c ioctls.h ioctldefs.h
- $(LINK.c) -I. -o $@ $<
+ $(filter-out -I%,$(LINK.c)) -I. -I$(IOCTLDIR) $(filter -I%,$(LINK.c)) \
+ -o $@ $<
ioctls.h: $(srcdir)/linux/ioctlent.sh
- $(SHELL) $< $(IOCTLDIR)
+ $(SHELL) $< $(IOCTLDIR) $(IOCTLASM)
ioctldefs.h: ioctls.h ;
endif