summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVineet Gupta <Vineet.Gupta1@synopsys.com>2013-08-16 12:47:06 +0530
committerDmitry V. Levin <ldv@altlinux.org>2013-09-11 14:44:54 +0000
commit7daacbbbe7349677476a3d2fbf174dcf86f171be (patch)
tree7e1488f3451b29804ff007f35d5dc30594f3a4f5 /configure.ac
parent16b9dcf8b870f47305aa2db174f5abccefb7cd94 (diff)
downloadstrace-7daacbbbe7349677476a3d2fbf174dcf86f171be.tar.gz
strace-7daacbbbe7349677476a3d2fbf174dcf86f171be.tar.bz2
strace-7daacbbbe7349677476a3d2fbf174dcf86f171be.tar.xz
Add support for ARC Cores from Synopsys
Take #2 on mainlining strace support for ARC (last one was 4.6 based back in March 2011), see http://sourceforge.net/p/strace/mailman/message/27210168/ The syscall ABI is asm-generic/unistd.h based (so no legacy syscalls), hence very similar to metag port. test/* all seem to work well. * linux/arc/ioctlent.h.in: New file. * linux/arc/syscallent.h: Likewise. * Makefile.am (EXTRA_DIST): Add linux/arc/ioctlent.h.in and linux/arc/syscallent.h. * configure.ac: Add ARC to the list of supported architectures. * defs.h: Add ARC support. * process.c (struct_user_offsets): Likewise. * signal.c (sys_sigreturn): Likewise. * syscall.c (print_pc, get_regset, get_regs, get_scno, get_syscall_args, get_syscall_result, get_error): Likewise. * util.c (change_syscall): Likewise. Signed-off-by: Vineet Gupta <vgupta@synopsys.com> Acked-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3b62e8..f19e4f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,10 @@ avr32*)
arch=avr32
AC_DEFINE([AVR32], 1, [Define for the AVR32 architecture.])
;;
+arc*)
+ arch=arc
+ AC_DEFINE([ARC], 1, [Define for the ARC architecture.])
+ ;;
s390)
arch=s390
AC_DEFINE([S390], 1, [Define for the S390 architecture.])