summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2010-09-09 17:41:15 +0000
committerDmitry V. Levin <ldv@altlinux.org>2010-09-09 23:20:25 +0000
commit918e49bac792ffb3ed48a33fadcb94e1833e953c (patch)
tree354bb291eb1e312bd9556ef16c35bc122adaecb3 /configure.ac
parent916adeda63abe70b8a5731e7cddcb84c940908f9 (diff)
downloadstrace-918e49bac792ffb3ed48a33fadcb94e1833e953c.tar.gz
strace-918e49bac792ffb3ed48a33fadcb94e1833e953c.tar.bz2
strace-918e49bac792ffb3ed48a33fadcb94e1833e953c.tar.xz
Import warnings.m4 from gnulib
* m4/warnings.m4: Replace with warnings.m4 from gnulib. * configure.ac: Use gl_WARN_ADD from new warnings.m4. * Makefile.am (AM_CFLAGS): Update for new warnings.m4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 96a9a66..3a392aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,15 +171,13 @@ in the compilation directory.])
fi
fi
-AC_WARNFLAGS
+gl_WARN_ADD([-Wall])
if test "x$opsys" = "xsunos4"
then
- if test -n "$GCC"
- then
- # SunOS 4.x header files don't declare int functions.
- WARNFLAGS="$WARNFLAGS -Wno-implicit"
- fi
+ # SunOS 4.x header files don't declare int functions.
+ gl_WARN_ADD([-Wno-implicit])
fi
+AC_SUBST([WARN_CFLAGS])
AC_PROG_CPP
AC_PROG_GCC_TRADITIONAL