summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2003-01-10 19:55:30 +0000
committerRoland McGrath <roland@redhat.com>2003-01-10 19:55:30 +0000
commita7a0d38a4cb226b09df78060e649181cfc1f68b3 (patch)
tree2a31984e714b36b137991b9a4ce450277510bcb7 /configure.ac
parentca16be8be9521b61bd2c5d945aa115519ebcb4da (diff)
downloadstrace-a7a0d38a4cb226b09df78060e649181cfc1f68b3.tar.gz
strace-a7a0d38a4cb226b09df78060e649181cfc1f68b3.tar.bz2
strace-a7a0d38a4cb226b09df78060e649181cfc1f68b3.tar.xz
2003-01-10 Roland McGrath <roland@redhat.com>
* configure.ac: Fix siginfo_t/sig_atomic_t checks. Use prerequisite #include <netinet/in.h> for netinet/*.h checks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b99effc..664a5c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,7 +167,7 @@ AC_TYPE_UID_T
AC_TYPE_MODE_T
AC_TYPE_GETGROUPS
AC_HEADER_MAJOR
-AC_CHECK_TYPES(sig_atomic_t siginfo_t,,, [#include <signal.h>])
+AC_CHECK_TYPES([sig_atomic_t. siginfo_t],,, [#include <signal.h>])
AC_CHECK_MEMBERS([struct sockaddr_in6.sin6_scope_id],,, [#include <netinet/in.h])
AC_CHECK_TYPES([long long])
AC_LITTLE_ENDIAN_LONG_LONG
@@ -181,10 +181,11 @@ AC_CHECK_LIB(nsl, main)
fi
AC_CHECK_FUNCS(sigaction strerror strsignal pread sys_siglist _sys_siglist getdents mctl prctl sendmsg inet_ntop if_indextoname)
-AC_CHECK_HEADERS([sys/reg.h sys/filio.h sys/acl.h sys/asynch.h sys/door.h stropts.h sys/conf.h sys/stream.h sys/tihdr.h sys/tiuser.h sys/sysconfig.h ioctls.h sys/ioctl.h sys/ptrace.h termio.h linux/ptrace.h asm/reg.h sys/uio.h sys/aio.h poll.h sys/poll.h sys/vfs.h netinet/tcp.h netinet/udp.h asm/sysmips.h linux/utsname.h sys/nscsys.h], [], [])
+AC_CHECK_HEADERS([sys/reg.h sys/filio.h sys/acl.h sys/asynch.h sys/door.h stropts.h sys/conf.h sys/stream.h sys/tihdr.h sys/tiuser.h sys/sysconfig.h ioctls.h sys/ioctl.h sys/ptrace.h termio.h linux/ptrace.h asm/reg.h sys/uio.h sys/aio.h poll.h sys/poll.h sys/vfs.h asm/sysmips.h linux/utsname.h sys/nscsys.h], [], [])
AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
[], [], [#include <linux/socket.h>])
AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+AC_CHECK_HEADERS([netinet/tcp.h netinet/udp.h],,, [#include <netinet/in.h>])
AC_MP_PROCFS
AC_POLLABLE_PROCFS
@@ -192,6 +193,11 @@ AC_POLLABLE_PROCFS
AC_CHECK_MEMBERS([struct msghdr.msg_control],,, [#include <sys/socket.h>])
AC_STRUCT_PR_SYSCALL
+AC_CHECK_MEMBERS([struct T_conn_res.QUEUE_ptr,
+ struct T_conn_res.ACCEPTOR_id],,,
+[#include <sys/stream.h>
+#include <sys/tihdr.h>])
+
AC_CHECK_DECLS([sys_errlist])
AC_CHECK_DECLS([sys_siglist, _sys_siglist],,, [#include <signal.h>])