summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@linux-m68k.org>2010-07-12 21:39:57 +0200
committerAndreas Schwab <schwab@linux-m68k.org>2010-07-13 19:13:03 +0200
commitd69fa497f4729373618fb7b506a2362422487ab1 (patch)
tree675c8d6f0d44d922c1f90f3f2a6ebab7e6274179 /configure.ac
parent372cc84c972f8e88cc148f343b02f4b5beb83dc7 (diff)
downloadstrace-d69fa497f4729373618fb7b506a2362422487ab1.tar.gz
strace-d69fa497f4729373618fb7b506a2362422487ab1.tar.bz2
strace-d69fa497f4729373618fb7b506a2362422487ab1.tar.xz
Add biarch support for powerpc64
* acinclude.m4 (AC_LITTLE_ENDIAN_LONG_LONG): Use int instead of long. * configure.ac [$host_cpu = powerpc*]: Also define POWERPC64 if $host_cpu = powerpc64. * defs.h (SUPPORTED_PERSONALITIES, PERSONALITY0_WORDSIZE) (PERSONALITY1_WORDSIZE) [POWERPC64]: Define. * file.c: (struct stat_powerpc32, printstat_powerpc32) [POWERPC64]: Define. (printstat) [LINUX && POWERPC64]: Use printstat_powerpc32 in 32-bit personality. (sys_newfstatat) [POWERPC64]: Handle personalities. * signal.c (sys_sigreturn) [POWERPC64]: Likewise. * util.c (printllval) [POWERPC64]: Likewise. (printcall) [POWERPC64]: Use wider format for IP prefix. * syscall.c (get_scno) [POWERPC64]: Check for 64/32 bit mode. * linux/powerpc/errnoent1.h: New file. * linux/powerpc/ioctlent1.h: New file. * linux/powerpc/signalent1.h: New file. * linux/powerpc/syscallent1.h: New file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76f55d2..40fa15b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,9 @@ alpha*)
powerpc*)
arch=powerpc
AC_DEFINE([POWERPC], 1, [Define for the PowerPC architecture.])
+ if test $host_cpu = powerpc64; then
+ AC_DEFINE([POWERPC64], 1, [Define for the PowerPC64 architecture.])
+ fi
;;
arm*)
arch=arm