summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2004-08-31 08:17:22 +0000
committerRoland McGrath <roland@redhat.com>2004-08-31 08:17:22 +0000
commit368ccc64a9752bdb9862e308d21720559756d6f1 (patch)
treea241029404396cfec96bdad14de6584dfc8dcbc3 /debian/rules
parentb93f91835646292bb5469e2a81e57a1522d483bf (diff)
downloadstrace-368ccc64a9752bdb9862e308d21720559756d6f1.tar.gz
strace-368ccc64a9752bdb9862e308d21720559756d6f1.tar.bz2
strace-368ccc64a9752bdb9862e308d21720559756d6f1.tar.xz
2004-08-31 Roland McGrath <roland@redhat.com>
* debian/rules: Revert sparc64 change of 2004-07-12. It does not build properly. Fixes Debian bug #254728.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 1 insertions, 25 deletions
diff --git a/debian/rules b/debian/rules
index 6f99d66..cdce167 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,18 +3,6 @@
# Debian package information
package = strace
-DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
-ifeq ($(DEB_HOST_GNU_TYPE),sparc-linux)
- build64 = yes
- HOST64 = sparc64-linux
- CC64 = gcc -m64
-endif
-
-ifeq ($(build64),yes)
- extra_build_targets += stamp-build64
-endif
-
all build: Makefile
$(MAKE) $(MFLAGS)
touch stamp-build
@@ -25,19 +13,12 @@ clean:
test ! -f Makefile || $(MAKE) distclean
rm -f stamp-build
rm -rf debian/tmp debian/substvars debian/files
- rm -rf build64 stamp-build64
binary: binary-indep binary-arch
binary-indep:
-stamp-build64:
- mkdir build64
- cd build64 && CC="$(CC64)" sh ../configure --prefix=/usr --build=$(HOST64)
- cd build64 && $(MAKE) $(MFLAGS)
- touch $@
-
-binary-arch: $(extra_build_targets) build checkroot
+binary-arch: build checkroot
test -f stamp-build || make $(MFLAGS) -f debian/rules build
-rm -rf debian/tmp debian/files debian/substvars
@@ -64,11 +45,6 @@ binary-arch: $(extra_build_targets) build checkroot
install -p -o root -g root -m 644 strace.1 debian/tmp/usr/share/man/man1/strace.1
gzip -9 debian/tmp/usr/share/man/man1/strace.1
-ifeq ($(build64),yes)
- install -s -o root -g root -m 755 build64/strace debian/tmp/usr/bin/strace64
- ln -s strace.1 debian/tmp/usr/share/man/man1/strace64.1
-endif
-
dpkg-shlibdeps strace
dpkg-gencontrol -isp
dpkg --build debian/tmp ..