summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFrederik Schüler <fs@debian.org>2010-02-04 12:14:56 -0800
committerRoland McGrath <roland@redhat.com>2010-02-04 12:20:25 -0800
commit881f573876e2223ae5c2cedaa32a3b0d6b9ff339 (patch)
treecbdd58d8c8d29e133c08668a115eb72d1b5d6d03 /debian/rules
parent3de3d6bf5abdf410110aed1f844992304f6ae8b9 (diff)
downloadstrace-881f573876e2223ae5c2cedaa32a3b0d6b9ff339.tar.gz
strace-881f573876e2223ae5c2cedaa32a3b0d6b9ff339.tar.bz2
strace-881f573876e2223ae5c2cedaa32a3b0d6b9ff339.tar.xz
Update debian/* files
* debian/control: add sparc64 to the architectures list. This closes Debian bug #560062 * Backport commit f0df31e71a58c6e79ba77c1a9d84b2f38d44bec7 to fix FTBFS. This closes Debian bug #560516 * debian/control: Update standards-version to 3.8.3. * debian/control: Lower package priority to optional, matching the archive override. * debian/control: add ${misc:Depends} to Depends: lines where appropriate. * debian/watch: new file, allows automatic tracking of new upstream versions. * debian/source/format: new file, adapt to debian source format "quilt" * debian/rules: indentation cleanups; use dh_testroot and dh_prep in clean target.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 13 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c87b35a..62903fd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,14 @@
#! /usr/bin/make -f
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -35,6 +43,9 @@ build64/Makefile:
cd $(@D); CC="$(CC64)" sh ../configure --prefix=/usr --build=$(DEB_BUILD_GNU_TYPE) --host=$(HOST64)
clean:
+ dh_testdir
+ dh_testroot
+ dh_prep
dh_clean
rm -rf debian/strace debian/strace-udeb debian/substvars debian/files debian/files~
rm -rf build64 stamp-build64 strace64.1
@@ -44,7 +55,7 @@ binary: binary-indep binary-arch
binary-indep:
-binary-arch: build checkroot
+binary-arch: build
test -f stamp-build || make $(MFLAGS) -f debian/rules build
# prepare 64bit executable and manpage, if it has been built
@@ -68,6 +79,3 @@ binary-arch: build checkroot
dh_gencontrol -s
dh_md5sums -s
dh_builddeb -s
-
-checkroot:
- test root = "`whoami`"