summaryrefslogtreecommitdiff
path: root/packages/compression
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-12 19:44:49 +0100
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-01-12 19:44:49 +0100
commitaaa4ef2f19619968a8a8fe844e270e1615ecdf57 (patch)
tree79f6b5f7e4b4bde4f7ca08f6cddfcf2388d0f656 /packages/compression
parent6a73533bcd908d12a10fe3d62e7f551b1042b351 (diff)
downloadembtoolkit-aaa4ef2f19619968a8a8fe844e270e1615ecdf57.tar.gz
embtoolkit-aaa4ef2f19619968a8a8fe844e270e1615ecdf57.tar.bz2
embtoolkit-aaa4ef2f19619968a8a8fe844e270e1615ecdf57.tar.xz
packages/compression: convert to use include macro
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/compression')
-rw-r--r--packages/compression/compression.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/compression/compression.mk b/packages/compression/compression.mk
index a13e8f3..1a8068a 100644
--- a/packages/compression/compression.mk
+++ b/packages/compression/compression.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,11 +23,11 @@
# \date August 2010
################################################################################
-#lzo for host and target
-include packages/compression/lzo/lzo.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LZO) += lzo_install
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_LZO) += lzo_host_install
+embtk_pkgincdir := packages/compression
-#zlib for target
-include packages/compression/zlib/zlib.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_ZLIB) += zlib_install
+# lzo for host and target
+$(call embtk_include_pkg,lzo)
+$(call embtk_include_hostpkg,lzo_host)
+
+# zlib for target
+$(call embtk_include_pkg,zlib)