summaryrefslogtreecommitdiff
path: root/packages/htools/gmp
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:10 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:40 +0200
commit06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32 (patch)
tree7264e87fccedfd6dbfeb4671bff60b3d0d842794 /packages/htools/gmp
parentb1fb4b94943becfce0d4b7be268295bfffccceea (diff)
downloadembtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.gz
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.bz2
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.xz
Toolchain: move gmp, mpfr and gmp under host tools
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/gmp')
-rw-r--r--packages/htools/gmp/gmp.kconfig36
-rw-r--r--packages/htools/gmp/gmp.mk33
2 files changed, 69 insertions, 0 deletions
diff --git a/packages/htools/gmp/gmp.kconfig b/packages/htools/gmp/gmp.kconfig
new file mode 100644
index 0000000..3cb2dd0
--- /dev/null
+++ b/packages/htools/gmp/gmp.kconfig
@@ -0,0 +1,36 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gmp.kconfig
+# \brief gmp.kconfig of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+config EMBTK_HOST_HAVE_GMP
+ bool
+ default y
+
+config EMBTK_GMP_HOST_VERSION_STRING
+ string
+ default "5.0.4"
+
+config EMBTK_GMP_HOST_NEED_PATCH
+ bool
+config EMBTK_GMP_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/gmp/gmp.mk b/packages/htools/gmp/gmp.mk
new file mode 100644
index 0000000..467c6a9
--- /dev/null
+++ b/packages/htools/gmp/gmp.mk
@@ -0,0 +1,33 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gmp.mk
+# \brief gmp.mk of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+GMP_HOST_NAME := gmp
+GMP_HOST_VERSION := $(call embtk_get_pkgversion,gmp_host)
+GMP_HOST_SITE := ftp://ftp.gmplib.org/pub/gmp-$(GMP_HOST_VERSION)
+GMP_HOST_PACKAGE := gmp-$(GMP_HOST_VERSION).tar.bz2
+GMP_HOST_SRC_DIR := $(embtk_toolsb)/gmp-$(GMP_HOST_VERSION)
+GMP_HOST_BUILD_DIR := $(embtk_toolsb)/gmp-build
+
+GMP_HOST_CONFIGURE_OPTS := --disable-shared --enable-static