summaryrefslogtreecommitdiff
path: root/packages/htools/mpfr
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:10 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-09-12 00:03:40 +0200
commit06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32 (patch)
tree7264e87fccedfd6dbfeb4671bff60b3d0d842794 /packages/htools/mpfr
parentb1fb4b94943becfce0d4b7be268295bfffccceea (diff)
downloadembtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.gz
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.bz2
embtoolkit-06aa4f3ebffcf78b5fd3245171fc7b13a8e2ef32.tar.xz
Toolchain: move gmp, mpfr and gmp under host tools
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/htools/mpfr')
-rw-r--r--packages/htools/mpfr/mpfr.kconfig37
-rw-r--r--packages/htools/mpfr/mpfr.mk36
2 files changed, 73 insertions, 0 deletions
diff --git a/packages/htools/mpfr/mpfr.kconfig b/packages/htools/mpfr/mpfr.kconfig
new file mode 100644
index 0000000..a944cf8
--- /dev/null
+++ b/packages/htools/mpfr/mpfr.kconfig
@@ -0,0 +1,37 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpfr.kconfig
+# \brief mpfr.kconfig of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+config EMBTK_HOST_HAVE_MPFR
+ bool
+ default y
+
+config EMBTK_MPFR_HOST_VERSION_STRING
+ string
+ default "2.4.2"
+
+config EMBTK_MPFR_HOST_NEED_PATCH
+ bool
+config EMBTK_MPFR_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/mpfr/mpfr.mk b/packages/htools/mpfr/mpfr.mk
new file mode 100644
index 0000000..87a7f74
--- /dev/null
+++ b/packages/htools/mpfr/mpfr.mk
@@ -0,0 +1,36 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file mpfr.mk
+# \brief mpfr.mk of Embtoolkit for toolchain
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date May 2009
+################################################################################
+
+MPFR_HOST_NAME := mpfr
+MPFR_HOST_VERSION := $(call embtk_get_pkgversion,mpfr_host)
+MPFR_HOST_SITE := http://www.mpfr.org/mpfr-$(MPFR_HOST_VERSION)
+MPFR_HOST_PACKAGE := mpfr-$(MPFR_HOST_VERSION).tar.bz2
+MPFR_HOST_SRC_DIR := $(embtk_toolsb)/mpfr-$(MPFR_HOST_VERSION)
+MPFR_HOST_BUILD_DIR := $(embtk_toolsb)/mpfr-$(MPFR_HOST_VERSION)-build
+
+MPFR_HOST_DEPS := gmp_host_install
+
+MPFR_HOST_CONFIGURE_OPTS := --disable-shared --enable-static
+MPFR_HOST_CONFIGURE_OPTS += --with-gmp=$(embtk_htools)