summaryrefslogtreecommitdiff
path: root/packages/misc
diff options
context:
space:
mode:
authorRicardo Crudo <ricardo.crudo@gmail.com>2014-05-17 14:15:10 -0300
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-05-17 22:41:44 +0200
commit2712c83eb51c033a74047cc5c592c285a46fab8b (patch)
tree96727f5d03a096800f088420f0283b17157802d0 /packages/misc
parentd9886c0e102356edcb56bbbc6a2e6907eb9c2070 (diff)
downloadembtoolkit-2712c83eb51c033a74047cc5c592c285a46fab8b.tar.gz
embtoolkit-2712c83eb51c033a74047cc5c592c285a46fab8b.tar.bz2
embtoolkit-2712c83eb51c033a74047cc5c592c285a46fab8b.tar.xz
Packages/misc: New sord v0.12.0
Signed-off-by: Ricardo Crudo <ricardo.crudo@gmail.com> Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/misc')
-rw-r--r--packages/misc/misc.kconfig3
-rw-r--r--packages/misc/misc.mk3
-rw-r--r--packages/misc/sord/sord.kconfig52
-rw-r--r--packages/misc/sord/sord.mk47
4 files changed, 105 insertions, 0 deletions
diff --git a/packages/misc/misc.kconfig b/packages/misc/misc.kconfig
index 537ba33..395122f 100644
--- a/packages/misc/misc.kconfig
+++ b/packages/misc/misc.kconfig
@@ -43,5 +43,8 @@ source packages/misc/libxml/libxml.kconfig
# serd
source packages/misc/serd/serd.kconfig
+# sord
+source packages/misc/sord/sord.kconfig
+
# tslib
source packages/misc/tslib/tslib.kconfig
diff --git a/packages/misc/misc.mk b/packages/misc/misc.mk
index 02fdb9d..3cd34f1 100644
--- a/packages/misc/misc.mk
+++ b/packages/misc/misc.mk
@@ -49,5 +49,8 @@ $(call embtk_include_pkg,ncurses)
# serd
$(call embtk_include_pkg,serd)
+# sord
+$(call embtk_include_pkg,sord)
+
# tslib
$(call embtk_include_pkg,tslib)
diff --git a/packages/misc/sord/sord.kconfig b/packages/misc/sord/sord.kconfig
new file mode 100644
index 0000000..b0cf993
--- /dev/null
+++ b/packages/misc/sord/sord.kconfig
@@ -0,0 +1,52 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file sord.kconfig
+# \brief sord.kconfig of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+config EMBTK_HAVE_SORD
+ bool "Have sord"
+ select EMBTK_HAVE_SERD
+ help
+ Sord is a lightweight C library for storing RDF data in memory.
+
+choice
+ prompt "sord version to use"
+ depends on EMBTK_HAVE_SORD
+ help
+ sord version to use
+
+ config EMBTK_SORD_VERSION_0_12_0
+ bool "sord-0.12.0"
+endchoice
+
+config EMBTK_SORD_USE_WAF
+ bool
+ default y
+ select EMBTK_HOST_HAVE_WAF
+
+config EMBTK_SORD_VERSION_STRING
+ string
+ default "0.12.0" if EMBTK_SORD_VERSION_0_12_0
+
+config EMBTK_SORD_NEED_PATCH
+ bool
diff --git a/packages/misc/sord/sord.mk b/packages/misc/sord/sord.mk
new file mode 100644
index 0000000..375bf25
--- /dev/null
+++ b/packages/misc/sord/sord.mk
@@ -0,0 +1,47 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file sord.mk
+# \brief sord.mk of Embtoolkit.
+# \author Ricardo Crudo <ricardo.crudo@gmail.com>
+# \date May 2014
+################################################################################
+
+SORD_NAME := sord
+SORD_VERSION := $(call embtk_get_pkgversion,sord)
+SORD_SITE := http://download.drobilla.net
+SORD_PACKAGE := sord-$(SORD_VERSION).tar.bz2
+SORD_SRC_DIR := $(embtk_pkgb)/sord-$(SORD_VERSION)
+SORD_BUILD_DIR := $(embtk_pkgb)/sord-$(SORD_VERSION)
+
+SORD_DEPS := serd_install
+SORD_BINS := sord_validate sordi
+SORD_INCLUDES := sord-0
+SORD_LIBS := libsord*
+SORD_PKGCONFIGS := sord-0.pc
+SORD_SHARES := man/*/sord*
+
+# uses python2 to execute the waf due a bug with waflib and python 3.4.0
+define embtk_beforeinstall_sord
+ cp $(SORD_SRC_DIR)/waf $(SORD_SRC_DIR)/waf.bak
+ sed -e 's;env[[:space:]]python;env python2;' \
+ < $(SORD_SRC_DIR)/waf > $(SORD_SRC_DIR)/waf.new
+ mv $(SORD_SRC_DIR)/waf.new $(SORD_SRC_DIR)/waf
+ chmod +x $(SORD_SRC_DIR)/waf
+endef